Help: Install python-2.1-3 on RedHat 7.1!

FunkyTritone mestesso100 at yahoo.com
Wed Jul 25 19:22:27 CEST 2001


Hi there, I just tried to install python-2.1-3 on RedHat 7.1
and I got lost in a RPM maze.
Basically I have to upgrade stuff like readline and libcrypto that
are needed by a bunch of other software. Is there any way to
have a clean install of this beast without breaking the whole
system? It shouldn't be that hard!!!

$> rpm -Uvh python-2.1-3.i686.rpm python-devel-2.1-3.i686.rpm
openssl-0.9.6b-3.i586.rpm ncurses-ext-5.2-4.i686.rpm
readline-4.2-6.i686.rpm gmp-2.0.2-15.i686.rpm ncurses-5.2-4.i686.rpm

error: failed dependencies:
        gmp = 3.1.1 is needed by gmp-devel-3.1.1-3
        libgmp.so.3   is needed by librep-0.13.3-1
        libgmp.so.3   is needed by sawfish-0.38-1
        readline = 4.1 is needed by readline-devel-4.1-9
        libreadline.so.4.1   is needed by ftp-0.17-7
        libreadline.so.4.1   is needed by librep-0.13.3-1
        libreadline.so.4.1   is needed by guile-1.3.4-12
        libreadline.so.4.1   is needed by openldap-clients-2.0.7-14
        libreadline.so.4.1   is needed by pilot-link-0.9.5-2
        libreadline.so.4.1   is needed by postgresql-7.0.3-8
        libreadline.so.4.1   is needed by postgresql-devel-7.0.3-8
        libreadline.so.4.1   is needed by postgresql-server-7.0.3-8
        libreadline.so.4.1   is needed by cdecl-2.5-17
        libreadline.so.4.1   is needed by bc-1.06-2
        libreadline.so.4.1   is needed by dump-0.4b21-3
        libreadline.so.4.1   is needed by amanda-2.4.2p2-1
        libreadline.so.4.1   is needed by amanda-client-2.4.2p2-1
        libreadline.so.4.1 is needed by ext2ed-0.1-23
        libreadline.so.4.1 is needed by fvwm2-2.2.4-9
        libreadline.so.4.1 is needed by gnuplot-3.7.1-12
        libreadline.so.4.1   is needed by amanda-server-2.4.2p2-1
        libreadline.so.4.1   is needed by mysql-3.23.36-1
        libreadline.so.4.1   is needed by parted-1.4.7-2
        libreadline.so.4.1   is needed by postgresql-tcl-7.0.3-8
        libreadline.so.4.1   is needed by postgresql-tk-7.0.3-8
        libreadline.so.4.1 is needed by units-1.55-9
        libreadline.so.4.1   is needed by x3270-text-3.2.14-1
        python = 2.0-9mdk is needed by tkinter-2.0-9mdk
        openssl = 0.9.6-9 is needed by openssl-perl-0.9.6-9
        openssl = 0.9.6-9 is needed by openssl-python-0.9.6-9
        openssl = 0.9.6-9 is needed by openssl-devel-0.9.6-9
        libcrypto.so.1   is needed by bind-utils-9.1.0-10
        libcrypto.so.1   is needed by slrn-0.9.6.4-2
        libcrypto.so.1   is needed by cyrus-sasl-1.5.24-17
        libcrypto.so.1   is needed by links-0.95-2
        libcrypto.so.1   is needed by openldap-2.0.7-14
        libcrypto.so.1   is needed by autofs-3.1.7-14
        libcrypto.so.1   is needed by nss_ldap-149-1
        libcrypto.so.1   is needed by openldap-clients-2.0.7-14
        libcrypto.so.1   is needed by pine-4.33-8
        libcrypto.so.1   is needed by sendmail-8.11.2-14
        libcrypto.so.1   is needed by fetchmail-5.7.4-4
        libcrypto.so.1   is needed by gq-0.4.0-2
        libcrypto.so.1   is needed by lynx-2.8.4-9
        libcrypto.so.1   is needed by mutt-1.2.5i-9
        libcrypto.so.1   is needed by openssh-2.5.2p2-5
        libcrypto.so.1   is needed by openssh-clients-2.5.2p2-5
        libcrypto.so.1   is needed by pidentd-3.0.12-4
        libcrypto.so.1   is needed by balsa-1.1.1-3
        libcrypto.so.1   is needed by kdebase-2.1.1-8
        libcrypto.so.1   is needed by samba-common-2.0.7-36
        libcrypto.so.1   is needed by samba-client-2.0.7-36
        libcrypto.so.1   is needed by openssh-server-2.5.2p2-5
        libcrypto.so.1   is needed by php-imap-4.0.4pl1-9
        libcrypto.so.1   is needed by php-ldap-4.0.4pl1-9
        libcrypto.so.1   is needed by bind-9.1.0-10
        libcrypto.so.1   is needed by ucd-snmp-4.2-12
        libcrypto.so.1   is needed by ucd-snmp-utils-4.2-12
        libcrypto.so.1   is needed by am-utils-6.0.5-1
        libcrypto.so.1   is needed by auth_ldap-1.4.7-2
        libcrypto.so.1   is needed by imap-2000-9
        libcrypto.so.1   is needed by licq-1.0.2-3
        libcrypto.so.1   is needed by openldap-servers-2.0.7-14
        libcrypto.so.1   is needed by stunnel-3.13-3
        libcrypto.so.1   is needed by samba-2.0.7-36
        libcrypto.so.1   is needed by mod_ssl-2.8.1-5
        libcrypto.so.1   is needed by kdevelop-1.4.1-2
        libcrypto.so.1   is needed by samba-swat-2.0.7-36
        libcrypto.so.1   is needed by slrn-pull-0.9.6.4-2
        libcrypto.so.1   is needed by squid-2.3.STABLE4-10
        libcrypto.so.1   is needed by xemacs-21.1.14-10
        libcrypto.so.1   is needed by kdelibs-2.1.2-1
        libcrypto.so.1   is needed by openssl-python-0.9.6-9
        libssl.so.1   is needed by slrn-0.9.6.4-2
        libssl.so.1   is needed by links-0.95-2
        libssl.so.1   is needed by openldap-2.0.7-14
        libssl.so.1   is needed by autofs-3.1.7-14
        libssl.so.1   is needed by nss_ldap-149-1
        libssl.so.1   is needed by openldap-clients-2.0.7-14
        libssl.so.1   is needed by pine-4.33-8
        libssl.so.1   is needed by sendmail-8.11.2-14
        libssl.so.1   is needed by fetchmail-5.7.4-4
        libssl.so.1   is needed by gq-0.4.0-2
...

)



More information about the Python-list mailing list