PEP0238 lament

Paul Prescod paulp at ActiveState.com
Tue Jul 24 01:21:32 CEST 2001


Duncan Grisby wrote:
> 
>...
> 
> The reality is that the whole world will not switch Python versions
> overnight, so everyone who maintains a library will have to face this
> issue.

All backwards compatibility issues are a matter of patience. Do you
think that anybody would complain if something that was deprecated
between Python 1.4 and Python 1.5 was formally removed now? Maybe it
will take ten years for us to provide a migration path to new-style
division. That is not an argument for putting of the beginning of that
process. If we had started two years ago we would be two years closer to
being able to fix the problem finally. It is Guido's job to take the
long view.
-- 
Take a recipe. Leave a recipe.  
Python Cookbook!  http://www.ActiveState.com/pythoncookbook




More information about the Python-list mailing list