Comment on PEP-0238

François Pinard pinard at
Sat Jul 7 19:45:15 EDT 2001

[Tim Peters]

> I want to make a pitch for naming it idiv() instead.  The "i" should
> strongly remind that the result is an integer, something "div" says only to
> former Pascal programmers.

idiv suggests FORTRAN to me! :-)  I prefer being remembered of Pascal! :-) :-)

And I like the idea of div(), mod() and divmod(): it's clean.

François Pinard

More information about the Python-list mailing list