integers

Michael P. Soulier msoulier at storm.ca
Wed Jun 6 22:34:32 EDT 2001


On Tue, 05 Jun 2001 18:39:26 -0700, Doug Landauer <landauer at apple.com> wrote:
> IMHO, it is 100 [*] times more important to make your code readable
> than it is to make it writeable.  So in order for a feature to
> pull its weight, it has to improve writeability by 100 times more
> than it impairs readability and maintainability.
> 
> IMHO, "++" does not fare well in this tradeoff.

    I'd agree that keeping side-effects separate is important if you want that
as a feature of the language, and that it would be confusing for former C
coders in the similarity. I can't buy the readability argument though. 

    Personally, I find var++ infinitely more readable than var += 1. 

    Although Pascal's incr() function is probably moreso. 

    Anyway, if you're going to add a feature, += makes more sense since you
can increment by variable amounts, but it's still less readable, IMHO. 

    Of course, if you add var++, do you add ++var? 

    Mike

-- 
Michael P. Soulier <msoulier at storm.ca> 
"With sufficient thrust, pigs fly just fine. However, this is not necessarily a
good idea. It is hard to be sure where they are going to land, and it could be
dangerous sitting under them as they fly overhead." -- RFC 1925



More information about the Python-list mailing list