Building 2.1 Issues

Thomas Wouters thomas at xs4all.net
Thu Jun 28 22:04:38 CEST 2001


On Thu, Jun 28, 2001 at 12:06:24PM -0600, Gregory Engel wrote:


> So I run:

> rpm -i /usr/src/redhat/RPMS/i386/expat-1.1-3tummy.i386.rpm
> rpm -q expat

> And get:
> expat-1.1-3tummy

> Looks good.  So I run:
> rpm --rebuild python2-2.1-5.src.rpm
> and STILL get back:
> 
> Installing python2-2.1-5.src.rpm
> error: failed build dependencies:
>         expat-devel >= 1.1-3tummy is needed by python2-2.1-5
>         db1-devel   is needed by python2-2.1-5

Note that python2-2.1-5.src.rpm needs expat-*devel*, not just expat. I guess
you can grab expat-devel-1.1-3tummy.{src,i386}.rpm from the same place you
got the expat RPM, probably Sean's site. It also needs db1-devel, which you
can grab from a RedHat CD or mirror.

Or-you-can-switch-to-Debian-which-will-have-2.1.1-in-a-few-weeks-ly y'rs ;)
-- 
Thomas Wouters <thomas at xs4all.net>

Hi! I'm a .signature virus! copy me into your .signature file to help me spread!




More information about the Python-list mailing list