Numeric 20.0.0 and 19.0.0 crash Python 2.1

Joal Heagney s713221 at student.gu.edu.au
Sat Jun 23 03:42:33 CEST 2001


Chad Everett wrote:
> 
> SuSE 7.1 Linux version 2.4.3-pre6 (gcc version 2.95.2
> 19991024 (release)) #1 SMP Wed Mar 21 17:18:55 MST 2001
> 
> I just installed Numeric-20.0.0 in my Python 2.1 (#1, Apr 18 2001, 12:17:25)
> and it is smooth.
> 
> My python 2.1 was just configured and built with:
> 
>         ./configure  --prefix=/opt/Python-2.1
> 
> On Fri, 22 Jun 2001 19:16:31 +0200 (MET DST), Daniel Reuter <reuter at Uni-Hohenheim.DE> wrote:
> >Hello there,
> >
> >When I do the following:
> >import Numeric
> >Python 2.1 crashes with a segmentation fault.
> >This is on a Debian/GNU Linux system, Python is configured --with-pymalloc

Here is the problem. Read up on the "What's New" of python2.1 about
pymalloc - basically it will crash certain third-party modules that
haven't quite followed the API. It didn't matter for previous releases
of python, but it matters for python2.1. Basically, if you want Numeric,
don't use --with-pymalloc on your python build.
As can be seen, the other poster was successful with is build, because
he didn't use pymalloc.
-- 
      Joal Heagney is: _____           _____
   /\ _     __   __ _    |     | _  ___  |
  /__\|\  ||   ||__ |\  || |___|/_\|___] |
 /    \ \_||__ ||___| \_|! |   |   \   \ !



More information about the Python-list mailing list