tummy compile Mandrake 7.2

myself twofingersalute at atl.mediaone.net
Sat Jun 9 03:37:10 CEST 2001


Greetings all!

long time lurker here, trying to compile  python2-2.1-4.src.rpm. Did a
"rpm -- rebuild expat-1.1-3tummy.src.rpm", installed the rpm, no probs,
then "rpm --rebuild  python2-2.1-4.src.rpm" chugs along but exits w/
following:

Processing files: python2-tools-2.1-4
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
line 246: Dependency tokens must begin with alpha-numeric, '_' or '/': %defattr(-, r
oot, root)
 
Failed to find Requires:
Requires: python2 = 2.1-4 /bin/bash

doesn't look like it's from spec file (lines 244-246):
%{__prefix}/lib/python2.1/distutils
%{__prefix}/lib/python2.1/encodings
%dir %{__prefix}/lib/python2.1/lib-old

I noticed this in spec file the aborted build left behind:

BuildPrereq: expat-devel >= 1.1-3tummy
BuildPrereq: db1-devel
BuildPrereq: gdbm-devel

already have gdbm-devel, got and installed db1 and db1-devel, no
clue as to expat-devel as Mr. tummy doesn't seem to install it.

tried again, fails again on same line, so doesn't look like it's referring
to spec file, as lines 245-246 are now:

%files -f tools.files tools
%defattr(-, root, root)

also, have following: rpm, rpm-build, rpm-devel  v.3.0.5-27mdk. My
goal here is to not only install Python2.1, but to learn a bit about installing
from source rpms (1'st time on the latter, just in case you hadn't guessed<g>).
target is i686(Athlon).

clues and/or nudges(wink, wink) in right direction appreciated.........



More information about the Python-list mailing list