New PEP: The directive statement

Darren New dnew at san.rr.com
Fri Mar 23 20:47:02 CET 2001


Andrew Kuchling wrote:
> It's really a documentation issue; people who release software should
> say "I've tested this with Python 2.0", and people with 1.5.2 or 2.1
> will have to look out, and perhaps provide patches to fix problems.

What is the Python mechanism for ensuring a particular (or minimal) version
of Python is being used? Is there one?  I'm talking about something like
Tcl's [package require Tcl 8.3] or some such.

-- 
Darren New / Senior MTS & Free Radical / Invisible Worlds Inc.
San Diego, CA, USA (PST).  Cryptokeys on demand.
A million monkeys in a room with a million typewriters 
              will only yield half a million pregnant monkeys.



More information about the Python-list mailing list