Zope and Python 2.1

kosh kosh at aesaeion.com
Mon May 14 00:38:45 CEST 2001


please post to the zope at zope.org list for the best change of getting help 
with zope.

Right now DC is updating zope for 2.1 but that is incurring many changes in 
it. Version 2.4 of zope will require python 2.1 and it is coming along 
pretty fast. If you look on zope.org the current zope news tells about the 
status of 2.4.

Magnus Lie Hetland wrote:

> 
> I just wondered... Has anyone been able to use Zope
> and Python 2.1 together out of the box? (Including
> possibly compiling them both out of the box,
> without any arcane editing of setup files etc.)
> 
> I get Python to work fine, but Zope seems to insist
> on looking for a Makefile.pre.in which isn't there...
> And the binary version has too old a version
> on the C API so I get a ton of warnings...
> 
> It seems that Zope doesn't even support Python 2.0
> "officially" yet; the installation instructions
> state that you should have Python 1.5.2. I hoped
> that meant "1.5.2 or newer"... But anyway, I would
> have thought that a basic running distribution
> should be possible?
> 
> (The binary version seems to _work_ with 2.1...
> But all the warnings make me a bit worried ;)
> 
> My objective is to make a simple procedure for
> installing python 2.1 and ZODB so that
> newbies (or almost-newbies) can follow it.
> 
> Any insights? Am I missing something obvious?
> Should I just forget about the warnings?
> 
> All help greatly appreciated.
> 
> --
> 
>   Magnus Lie Hetland         http://www.hetland.org
> 
>  "Reality is that which, when you stop believing in
>   it, doesn't go away."           -- Philip K. Dick
> 
> 
> 
> 




More information about the Python-list mailing list