ConfigParser module in 1.52 is buggy?

Mike C. Fletcher mcfletch at home.com
Tue May 29 13:39:34 CEST 2001


Note that it's possible to copy the 2.0 version of ConfigParser into a 1.5.2
distro if you eliminate a few unicode references.  Seems to work fine in my
app (though I've since moved that app to 2.0).  You could probably do the
same from a 2.1 copy.

IMO this is the kind of stuff that should be in a 1.5.3 (or whatever the
version scheme is for bug-fix releases) release, of course, the difficulty
is determining what "this kind of stuff" is.

Sigh,
Mike

-----Original Message-----
From: python-list-admin at python.org
[mailto:python-list-admin at python.org]On Behalf Of Thomas Wouters
Sent: May 29, 2001 05:47
To: Brian Lee
Cc: python-list at python.org
Subject: Re: ConfigParser module in 1.52 is buggy?
...
[ ConfigParser barfs on that in 1.5.2, but not in 2.1 ]

Given that 1.5.2 is older than 2.1, it's entirely likely that it's a bug in
1.5.2 ;) (Note, 1.5.2, not 1.52; the 1.x series didn't go past 1.6 (yet ;))
There were 23 (!) checkins to the ConfigParser module between 1.5.2 and 2.1,
and only 9 (*nine*) checkins before that. There really is a reason we call
2.1 'the newer version', you know :-)
...





More information about the Python-list mailing list