2.1.1 build fails on hpux

george young gry at ll.mit.edu
Tue Oct 16 20:54:03 CEST 2001


On an hp machine (uname -a --> HP-UX hp93k B.10.20 A 9000/785 2014221311 two-user license),
aCC --version --> aCC: HP ANSI C++ B3910B A.01.23

./configure --without-threads --without-gcc --with-cxx=aCC --prefix=/opt/python
...
make
...
         cc -Ae  -Wl,-E -Wl,+s -Wl,+b/opt/python/lib/python2.1/lib-dynload -o python \
                        Modules/ccpython.o \
                        libpython2.1.a -ldld    -lm  
/usr/ccs/bin/ld: (Warning) At least one PA 2.0 object file (Modules/ccpython.o) was detected. The linked output may not run on a PA 1.x system.
/usr/ccs/bin/ld: Unsatisfied symbols:
   _main (code)
*** Error exit code 1

Help!
	-- George
-- 
 I cannot think why the whole bed of the ocean is
 not one solid mass of oysters, so prolific they seem. Ah,
 I am wandering! Strange how the brain controls the brain!
	-- Sherlock Holmes in "The Dying Detective"



More information about the Python-list mailing list