trouble running Grail

Lance E Sloan lsloan at umich.edu
Fri Sep 7 22:33:53 CEST 2001


I know this isn't a Grail support mailing list, but since I am in the
process of learning Python, I thought his might be a good place to
ask about this.

I'm using a Sun machine running Solaris 2.6 with Python 2.0 installed.
I downloaded Grail 0.6 and when I try to run it, I get this error:
    
    Traceback (most recent call last):
      File "grail.py", line 499, in ?
        main()
      File "grail.py", line 108, in main
        app = Application(prefs=prefs, display=display)
      File "grail.py", line 248, in __init__
        self.stylesheet = Stylesheet.Stylesheet(self.prefs)
      File "/var/tmp/grail-0.6/Stylesheet.py", line 21, in __init__
        self.load()
      File "/var/tmp/grail-0.6/Stylesheet.py", line 45, in load
        massaged.append((g, c), v % fparms_dict)
    TypeError: append requires exactly 1 argument; 2 given

Why would the Grail author give two arguments to append?  Was
there an old version of Python that allowed two arguments?

--
Lance E Sloan
Web Services, Univ. of Michigan: Full-service Web and database design,
development, and hosting.  Specializing in Python & Perl CGIs.
http://websvcs.itd.umich.edu/ - "Putting U on the Web"




More information about the Python-list mailing list