Python Install-Installed Python 2 on top of python 1.5

Ignacio Vazquez-Abrams ignacio at
Thu Sep 6 06:18:16 CEST 2001

On Thu, 6 Sep 2001, A.A wrote:

> Hello,
> I installed an rpm of Python 2.1.1, by right-clicking on it, and
> clicking upgrade. But my python1.5 installation still exists. And If I
> try to uninstallpython 1.5 from the RPM Manager, it raises an error
> saying, dependency problems with so-and-so programs.
> IS there a way to unistall Python 1.5 cleanly ??
> Thanks,
> Best Regards,
> Ahsan

Generally no, because there are a lot of RPM dependencies on it (as you've
discovered). There really is no harm in having both installed; I myself have
both on several machines I use. All you have to do to start version 2.1.1
instead of 1.5.2 is run 'python2.1' instead of just 'python'.

Ignacio Vazquez-Abrams  <ignacio at>

More information about the Python-list mailing list