sockets and freebsd (works w/ 2.1.3 but not 2.2.1)

Tracy Ruggles tracy at reinventnow.com
Wed Aug 21 06:51:56 CEST 2002


Hi all,

Just downloaded and installed Python 2.2.1 and tried to run configure and
then make, but they both stumbled on building the socket extension:

   building '_socket' extension
   gcc -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -DUSE_SSL=1 -I.
-I/usr/home/axiomf/usr/local/share/Python-2.2.1/./Include
-I/usr/local/include -IInclude/ -c
/usr/home/axiomf/usr/local/share/Python-2.2.1/Modules/socketmodule.c -o
build/temp.freebsd-4.4-RELEASE-i386-2.2/socketmodule.o
    cc -shared build/temp.freebsd-4.4-RELEASE-i386-2.2/socketmodule.o
-L/usr/local/lib -lssl -lcrypto -o
build/lib.freebsd-4.4-RELEASE-i386-2.2/_socket.so
   WARNING: removing "_socket" since importing it failed

Everything else seemed to come through okay, and aftern installing, Python
itself seemd to be working fine except when I try to use anything that
imports socket (and _socket), which happens to be most everything.

I tried configuring with- and without-threads, but to no avail.  There was
an installation of 2.1.3 on this system that worked fine with sockets.

I ran the above gcc and cc commands straight from the command line and
moved the _socket.so file to python's lib directory just to see what would
happen:

   axionf% python
   Python 2.2.1 (#5, Aug 21 2002, 03:45:02) 
   [GCC 2.95.3 20010315 (release) [FreeBSD]] on freebsd4
   Type "help", "copyright", "credits" or "license" for more information.
   >>> import socket
   Traceback (most recent call last):
     File "<stdin>", line 1, in ?
     File "/usr/home/axiomf/usr/local/lib/python2.2/socket.py", line 41, in ?
       from _socket import *
   ImportError: /usr/lib/libssl.so.2: Undefined symbol "OpenSSLDie"
   >>> 

Does anybody have a clue what's going on here?

Thanks,
Tracy



More information about the Python-list mailing list