'import mod_python' fails -- It works!!

Peter Bittner peter.bittner at gmx.net
Thu Aug 1 11:01:45 CEST 2002


Hi there!

Now it works! I had to create the following symbolic link:

# ln -s /usr/lib/apache/lib/python2.2/site-packages/mod_python
/usr/lib/python2.2/site-packages/mod_python

I still need the PythonPath directive in my httpd.conf file though,
without that it doesn't seem to work:
    PythonPath "['/usr/lib/apache/lib/python2.2',
'/usr/lib/apache/lib/python2.2/site-packages']"

Is this normal?

Now I'm only getting 'ordinary Python errors' (as below), I hope I can
figure out those problems on my own. (Although the error messages seem
really odd to me! ':-)) - Any suggestions?

Thanks to everyone!
Peter


-----------------------------------------------------snip!---
Mod_python error: "PythonHandler mod_python.publisher"

Traceback (most recent call last):

  File "/usr/lib/apache/lib/python2.2/site-packages/mod_python/apache.py",
line 181, in Dispatch
    module = import_module(module_name, _req)

  File "/usr/lib/apache/lib/python2.2/site-packages/mod_python/apache.py",
line 338, in import_module
    module = imp.load_module(mname, f, p, d)

  File "/usr/lib/apache/lib/python2.2/site-packages/mod_python/publisher.py",
line 64, in ?
    import base64

  File "/usr/lib/apache/python2.2/base64.py", line 7, in ?
    import binascii

ImportError: No module named binascii
-----------------------------------------------------snap!---



More information about the Python-list mailing list