sockets and freebsd (works w/ 2.1.3 but not 2.2.1)

Tracy Ruggles trace at reinventnow.com
Thu Aug 22 22:03:16 CEST 2002


On 22/8/02 at 10.19p, Andrew MacIntyre (andymac at bullseye.apana.org.au) said:

>On Wed, 21 Aug 2002, Tracy Ruggles wrote:
>
>> Just downloaded and installed Python 2.2.1 and tried to run configure and
>> then make, but they both stumbled on building the socket extension:
>
>{...}
>
>> I ran the above gcc and cc commands straight from the command line and
>> moved the _socket.so file to python's lib directory just to see what would
>> happen:
>>
>>    axionf% python
>>    Python 2.2.1 (#5, Aug 21 2002, 03:45:02)
>>    [GCC 2.95.3 20010315 (release) [FreeBSD]] on freebsd4
>>    Type "help", "copyright", "credits" or "license" for more information.
>>    >>> import socket
>>    Traceback (most recent call last):
>>      File "<stdin>", line 1, in ?
>>      File "/usr/home/axiomf/usr/local/lib/python2.2/socket.py", line 41, in ?
>>        from _socket import *
>>    ImportError: /usr/lib/libssl.so.2: Undefined symbol "OpenSSLDie"
>>    >>>
>>
>> Does anybody have a clue what's going on here?
>
>I can't replicate this on a stock 4.4-RELEASE system.
>
>The failure is that Python (as built) expects the SSL library
>(libssl.so.2) to have a symbol "OpenSSLDie", but your copy of that
>library doesn't have that symbol.
>
>Have you attempted to update the SSL library by any chance?

No, I'm running on a shared system: a VPS (virtual private server) through NTT/Verio (http://hosting.verio.com/index.php/vps_standard.html).

Is it possible that they're copy of libssl.so.2 is corrupted or incompatable?  I haven't tried to duplicate the problem by building and installing 2.1.3 or earlier.  Their support staff didn't have any ideas when I presented them with this problem.  Though, I will ask them specifically about this particular library.

--Tracy




More information about the Python-list mailing list