RPM's dependencies not found

Skip Montanaro skip at pobox.com
Sat Aug 31 00:38:51 CEST 2002


    Robert> I'm trying to upgrade my SuSE Linux 7.3 Pro Linux box to Python
    Robert> 2.2.1 (currently 2.1.1).  I downloaded the SRPM file and tried
    Robert> to do the rebuild.  It claimed that two needed rpm's weren't
    Robert> found, expat-devel and gdbm-devel.  I downloaded both of these
    Robert> RPM's and installed them with "kpackage".  But still got the two
    Robert> dependency errors.  What directory do I need to be in when I
    Robert> perform the -rebuild of the SRPM?  Or am I missing some
    Robert> environment variable settings or something?

Someone else reported that the expat rpm was named somewhat differently on
SuSE than RedHat.  I suspect you'll have to figure out what those two
packages are named on your system and tweak the spec file or something.

BTW, your email address doesn't seem to be working.  Earthlink says it has
no user named "Oschler".

-- 
Skip Montanaro
skip at pobox.com
consulting: http://manatee.mojam.com/~skip/resume.html




More information about the Python-list mailing list