Py2Exe Problem - warning: strop functions are obsolete; use string methods

Steve Greiner steve_greiner at pobox.com
Mon Aug 5 17:39:14 CEST 2002


On Fri, 2 Aug 2002 10:00:13 +0200, "Thomas Heller"
<theller at python.net> wrote:

>"Steve Greiner" <steve_greiner at pobox.com> wrote in message news:ed6b47bf.0208011746.4c351dd9 at posting.google.com...
>> I can't figure out something (I admit, I'm a little dense) that
>> doesn't seem to be a problem for anyone else, so I'm assuming I'm
>> doing something wrong.  I'm hoping someone will be kind enough to
>> point me to the obvious.
>>
>> I'm trying to make a stand-alone executable, which seems build just
>> fine.  But, when I run it, I get a constant stream of:
>>
>> warning: strop functions are obsolete; use string methods
>> warning: strop functions are obsolete; use string methods
>> warning: strop functions are obsolete; use string methods
>> .
>> .
>> .
>>
>> until I hit <Ctrl>-<Break>.  So, I tried a (very) small sample program
>> that also fails whenever I import other modules.  If I comment out the
>> import sys line, it runs fine.  Here's to code and output:
>>
>
>> I've grabbed the latest version of Python and Py2Exe this week, but
>> perhaps I've got my configuration screwed up, nonetheless.
>>
>Probably. This problem should be gone.
>I suggest you remove your build and dist directory, and try again.
>If this doesn't help, completely remove the python22\lib\site-packages\py2exe
>directory, install  py2exe again and it should work.
>
>I had no problems building your sample with py2exe-0.3.3 and python2.2.1
>(although I use win2k, you seem to use win98).
>
>Thomas
>

(Apologies to all for posting this - I've tried sending via email, but
am getting an "undeliverable" message.)

Thomas,

  Thanks for taking the time to look at this.  I've
uninstalled/reinstalled (with reboots in-between) Py2Exe, and did an
installation repair on Python 2.2.1.  You are correct, I am using
Win98.  I also have tons of stuff on my system (a laptop), so there
could be "interference" from several quarters.

  Anyhow, the problem has remained.  The only thing I didn't reinstall
were the PythonWin extensions, but when I reinstalled everything, I
ran the build and the run test from the console, so I didn't use that
environment.  I suppose some DLLs or registry entry from that could be
at fault...(?)

  If/when I figure this out, I'll let you know.  In the meantime, I do
appreciate your effort, and don't expect you to spend time on this,
since I seem to be a very isolated case.  If you want to know anything
about my setup, though, or to give something a try, please let me
know.

  - Steve



-----------== Posted via Newsfeed.Com - Uncensored Usenet News ==----------
   http://www.newsfeed.com       The #1 Newsgroup Service in the World!
-----= Over 100,000 Newsgroups - Unlimited Fast Downloads - 19 Servers =-----



More information about the Python-list mailing list