Linux and Python scripts, help needed

Ron Stephens rdsteph at earthlink.net
Sun Feb 10 15:58:28 CET 2002


Hmmm, thanks for your comments. I just noticed that in my syslogs there
was an attempt to open /etc/news/inn.conf that failed. So I just went in
and chown 'ed that file to be owned by me rather than root. I don't know
if that is part of the problem. But in general, I am finding that almost
nothing I try to do with respect to running Python scripts using crontab
works at first, simply because of all the permission stuff. So I change
ownership and rights a lot. But I didn't even know that
/etc/news/inn.conf was needed, and maybe it isn't! I wonder what else is
needed but not owned or allowed by my user? How does one ever get any
real work done when unknown permission and file ownership problems lurk
under every hidden log ;-))))

Pedro Rodriguez wrote:
> 
> "Ron Stephens" <rdsteph at earthlink.net> wrote:
> 
> > So this morning at 4:30 AM I sat up and ran a "top" process from the
> > Bash shell, that shows all
> > running processes. Sure enough, at exactly 4:30 AM, a new Python process
> > was spawned. The new
> > Python process was matched with a new entry in the cron log file of the
> > mygale.py program being
> > called.
> >
> >
> Seems we have another 'Courageous' here ;) At least, it proves that your
> cron setup is OK.
> 
> > I watched carefully, and the mygale.py process lasted for about 30
> > seconds and then disappeared from
> > the "top" screen. I assume it terminated normally. Except that when I
> > run the mygale.py get all script
> > manually  in the BASH shell, it takes about two minutes to complete.
> > This is the only sign of any
> > problem, but still no error messages are generated anywhere I can find.
> >
> >
> Call me stupid, but if I had to do this on my machine, I will need to
> startup my dialup connexion first, and ensure that the connection is ok
> prior starting anything. But maybe you have a permanent connection.
> 
> Some hints :
> - did the same script runs fine when runned manualy at the same hour ?
>   (thinking that the sites you access may be down for backup for example)
> - do you set up something special when you login manualy (like
>   environment variables required for your scripts) ? If you set up
>   variables in .bash_profile they won't be available to your scripts.
> 
> > By the way, shouldn't it be possible to cut and paste from the BASH
> > shell to a text editor? It would save me a lot of typing ;-))))
> >
> > The clipboard in general is a frustration; I can't yet make it work
> > properly in many situations. Is it me or does the KDE clipboard lack a
> > lot of functionality compared to Windows clipboard? I can't even copy
> > and paste from K-EDIT, nor K-WORD, to Netscape Composer. Oh, well.
> >
> >
> Works fine to me. But, I did notice the following thing :
> - run netscape composer
> - run kedit
> - type something in kedit
> - select it and copy it (Menu:Edit/Copy)
> - go back in netscape composer
> - paste is not available in Edit menu...
> - ... but middle button click works fine (X11 Paste)
> 
> > One last frustration: Linux does hang, at least to the point that this
> > newbie can't recover from it. My
> > box hung when I tried to open a web presentation by Guido van Rossum
> > about Python Conference 10
> > using K Presenter.  I could not even open a console nor close the
> > offending KDE shell to get back to a
> > command line. The box also hangs when I try to print using cups on my HP
> > T45 printer. (I wish I could
> > use my printer.) My downloaded Open Office also hangs my computer just
> > by trying to open it.
> >
> Same problem with kpresenter. The system start swapping and its very
> difficult (well almost impossible) to take control back. Even an old
> powerpoint viewer runned with wine wasn't able to open it.
> 
> Regards,
> --
> 
> Pedro



More information about the Python-list mailing list