Compiling python 2.2 with history command line support

Andrew MacIntyre andymac at bullseye.apana.org.au
Wed Jan 9 09:31:10 CET 2002


On 8 Jan 2002, Chris Reay wrote:

> > I compiled python 2.2 on a debian 2.2 (too) with the curses support but the
> > command line mode has no advanced edition support (history...)
> > What did I miss ?
>
> You need to download the libreadline (and libreadline_dev?) packages.
> apt-get install or dselect; you know the drill. Then rebuild python,
> of course.

Why do you need to rebuild Python?  Last time I looked the readline
module works fine as a loadable module, and if available is autoloaded.

--
Andrew I MacIntyre                     "These thoughts are mine alone..."
E-mail: andymac at bullseye.apana.org.au  | Snail: PO Box 370
        andymac at pcug.org.au            |        Belconnen  ACT  2616
Web:    http://www.andymac.org/        |        Australia





More information about the Python-list mailing list