building on hpux 10.20

Michael P. Soulier msoulier at nortelnetworks.com_.nospam
Wed Jun 5 13:29:32 CEST 2002


    Hello. I have Python 1.5.2 and Python 2.0 both built on HP-UX 10.20 with
no problems. However, I just tried building 2.2.1, and I got this error
immediately in the compile:

gcc -c -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I. -I./Include
-DHAVE_CONFIG_H  -o Modules/python.o Modules/python.c
In file included from /usr/include/limits.h:6,
                 from
/opt/corp/unsupported/lib/gcc-lib/hppa1.1-hp-hpux10.20/2.8.1/include/
limits.h:116,
                 from
/opt/corp/unsupported/lib/gcc-lib/hppa1.1-hp-hpux10.20/2.8.1/include/
syslimits.h:7,
                 from
/opt/corp/unsupported/lib/gcc-lib/hppa1.1-hp-hpux10.20/2.8.1/include/
limits.h:11,
                 from Include/Python.h:27,
                 from Modules/python.c:3:
/usr/include/sys/stdsyms.h:244: #error "Large Files (ILP32) not supported in
strict ANSI mode."
In file included from Include/Python.h:62,
                 from Modules/python.c:3:
Include/pyport.h:480: #error "LONG_BIT definition appears wrong for platform
(bad gcc/glibc config?)."
gmake: *** [Modules/python.o] Error 1

    Has anyone seen this before? We won't be moving away from HP-UX 10.20 for
a while yet, so it would be nice to get this working.

    Mike

-- 
Michael P. Soulier, QX41, SKY  Tel: 613-765-4699 (ESN: 39-54699)
Optical Networks, Nortel Networks, SDE Pegasus
"...the word HACK is used as a verb to indicate a massive amount
of nerd-like effort."  -Harley Hahn, A Student's Guide to Unix



More information about the Python-list mailing list