Installation problems DCOracle2 & W2000

Talon talon34 at hotmail.com
Wed Jun 26 16:49:34 CEST 2002


In article <3D1934D1.3000707 at nospam.majid.fm>,
 Fazal Majid <news at nospam.majid.fm> wrote:

> Talon wrote:
> > I am having a heck of a time getting DCOracle2 to funcion properly.  I 
> > am running on a W2K machine, python2.1.3 and Zope 2.5.1, both of which 
> > run just fine.  I installed DCOracle2 and the ZOracleDA under Zope and 
> > it works fine.  But standalone python scripts don't see the dco2.py 
> > module.  So I tried to install DCOracle2 in the python21/lib folder.  I 
> > got that latest version from Zope.org and it said it installed properly.  
> > But it doesn't run.  If you try to import it into a script, you get 
> > complaints that it can't find this or that module, all of which are part 
> > of the Zope path.
> 
> I have gotten DCOracle2 to work correctly on my Windows 2000 setup with 
> 2.1.1 (but I haven't tried it with Zope). You do need to set your 
> Pythonpath environment variable correctly, as well as copy the correct 
> dco2.pyd (DLL) version for your Python and Oracle versions.
> 
> -- Fazal Majid
> 
> If you want to respond by email, take the nospam out of my email address.
> 

Thanks for the response Fazal.  I believe the python path is correct, as 
other python scripts run fine.  The dco2.pyd file is copied to the 
correct directory by the latest version of install.py that comes with 
it.  But when a script tries to import DCOracle2, I get an error saying 
it is looking for Buffer or DateTime, all of which are part of the Zope 
path.

Mark



More information about the Python-list mailing list