test_struct.py fails when building Python 2.2 on RedHat 6.2/alpha

Mike Carifio carifio.nospam at nospam.usys.com
Fri Mar 29 17:26:15 CET 2002


I've recently built Python 2.2 on a RedHat 6.2/alpha box.
When I run the regression test suite ('make test'), test_struct.py
fails with a floating point exception and stops the regression test
suite.

Some questions:

1) Is this a know error or have I discovered something new? I
     tried to find out if this error was seen before by going to
     the python bugs database
(http://sourceforge.net/tracker/?atid=105470&group_id=5470&func=browse)
     and searching the newsgroup in Google. Are there other sources? I
didn't
     find a good way to search the sourceforge bug tracker for specific
keywords (like
     'test_struct' or 'alpha').

2) Once I take test_struct.py out of the test list, the suite runs to
completion, but I still
     have 24 tests that have failed. Are all tests the same? For example, if
test_bsddb fails, is my installation
     bogus or should I just shy away from db files on RH6.2/alpha?  Is there
a document or
     file somewhere that tells me how to interpret these results?

3) And related to (2), is test_struct.py a "mandatory" test?

I guess the question I'm asking is: if some of the tests fail, is the build
to be distrusted? If there's a judgment
call to make here, how do I inform my judgement? Please advise at your
convenience. Thanks.





More information about the Python-list mailing list