Which Linux distribution

Magnus Lyckå magnus at thinkware.se
Mon Oct 7 02:06:11 CEST 2002


Jaroslav Gresula wrote:
> I've installed RH 7.3 recently and I'm pretty frustrated from their 
> approach to Python packages. It is almost impossible to switch to
> Python 2.x version since majority of their scripts is based on 1.5.x.

 From RH 8.0 Python 2.2.1 is the standard python, so the
problem with Red Hat can be fixed with an upgrade. I'm
sure most Linux distros will do though.

A number of Linux distros do depend on Python for various
tools though, which mean that upgrades to non backward
compatible versions might cause some problems.

Of course, there is nothing stopping you from having several
different pythons in any linux box, the questions is just that
"which python" might have to point at a certain version...




More information about the Python-list mailing list