Can't see field results in PyDelphi

Robert Oschler Oschler at earthlink.net
Fri Oct 18 20:11:26 CEST 2002


I set up a simple app in Delphi 6 with a TPythonEngine component linked to a
TPythonGUIInputOutput component.  I tried a few simple expression
evaluations, and they all worked fine showing the results of the expression
evaluation in the memo control that is set up to receive the results.

I then imported amazon.py, the Python interface to Amazon's SOAP web
services.  I did a search by author (X = amazon.searchByAuthor('lyons')).
The search appeared to execute fine, but when I try to inspect the returned
results, I don't see anything in the output memo control.  For example I
tried:

print X[0].ProductName

which from inside the PythonWin IDE would show:

Lyons on Horses

but when I try it from PyDelphi I don't get anything in the output memo
control.  I don't see any error messages either.

I tried both ExecStrings(memoOut.Lines) and ExecStrings(memoOut.Lines[0])
with the same results in either case.  Anyone got some ideas here on how I
can fix this?

By the way, I am extremely impressed by PyDelphi, big thanks to Morgan and
the guys.

-ro






More information about the Python-list mailing list