Tkinter support for tk 8.4

Martin v. Löwis loewis at informatik.hu-berlin.de
Mon Oct 14 17:48:43 CEST 2002


Martin Franklin <mfranklin1 at gatwick.westerngeco.slb.com> writes:

> This patch and another have been accepted into the cvs version of python
> the second patch is a couple of new functions in the tkFIleDialog module
> that allows you to select multiple files (provided you have tk 8.4)

I'd like to stress that people are encouraged to try this out. You
(probably) don't have to run the CVS version of Python - using Python
2.2 should be fine (of course, you will have to recompile _tkinter to
use tk 8.4 in case you've been using a precompiled Python installation).

You also don't have to check out the entire CVS tree: SF allows to
download individual files, such as Tkinter.py, or tkFileDialog.py.

If you find any problems with the new features, please don't hesitate
to report them, at sf.net/projects/python. It would be good to find
problems before Python 2.3 is released (which is still several months
in the future, of course). I'd like to thank Martin Franklin for
contributing these patches, and hope he'll look into bug reports as
well (if any bugs are found :-).

Regards,
Martin



More information about the Python-list mailing list