Annoyed - Python 2.2.1 BUG in calendar module

Phil Thompson phil at river-bank.demon.co.uk
Thu Oct 3 19:16:55 CEST 2002


On Thursday 03 October 2002 5:59 pm, Kaleb Pederson wrote:
> Ok.  I just finished a PyQt date widget wherein I created a wrapper
> around the calendar module to use as my backend.  The Calendar module,
> however, doesn't explicitly say that it doesn't work for dates pre-1970.
> The best case is that this is a DOCUMENTATION BUG.  I would prefer to
> see a more powerful date module that starts at the beginning of the
> Gregorian calendar.

QDate is valid from the start of the Gregorian calendar up to about 8000.

Phil




More information about the Python-list mailing list