Strange change in xmlrpclib behavior

Walt Leipold leipold at
Thu Sep 26 14:57:58 EDT 2002


> Walt> Any ideas?  (BTW, it's xmlrpclib v0.9.8, Win2000 SP2 and NT4 SP6.)
> Have you tried a more recent version of xmlrpclib and/or Python 2.2.1 or
> Python from CVS?

I am now using Python 2.1.1, have tried xmlrpclib v0.9.9 without 
success, and  I'm just about desperate enough to go to the Python 
CVS.  I haven't moved to Python 2.2 because I'd have to rebuild
my serial library (but I may have to do that).

However, what's *really* bugging me is that the code *used* to 
work; even if moving to a slightly newer version fixes it, how can
I be sure it won't fail again?  I shouldn't turn it over to my 
customer until I understand what broke it in the first place...  

I'll probably end up junking XML-RPC and writing the socket code
using UDP or something similar, just so I can trust it.


-- Walt

"If ignorance is bliss, why                           Walt Leipold
aren't there more happy people?"                   leipold at

More information about the Python-list mailing list