Is Python 2.1 for Solairs 8 broke on SunFreeware?

yaipa yaipa at aol.com
Fri Sep 13 20:05:16 CEST 2002


Problem:
I've downloaded Python 2.1 for Sparc Solairs 8 from Sunfreeware and run the
pkgadd to install it.  All seems fine until I try running a script that 
works just fine with ActiveState's build of Python 2.1 for Solaris.  When
I run Python 2.1 from Sunfreeware, Python throws an import error on the 
'time' module.

% /usr/local/bin/python CronTar.py -c cronTar.cfg
  Traceback (most recent call last):
    File "/export/fruid/bin/CronTar.py", line 26, in ?
      import time
  ImportError: ld.so.1: /usr/local/bin/python: fatal: 
    libgcc_s.so.1: open failed: No such file or directory
%
Am I required to have gcc installed also?

Our deployment model strictly uses the Solaris pkgadd command, 
so I require either Python 2.1 or 2.2 in a standard Solaris 
package format. 

Any ideas?



More information about the Python-list mailing list