Python 2.2.1 compatible with Tcl/Tk 8.4?

Paul Moore gustav at
Sat Sep 21 21:42:07 CEST 2002

loewis at (Martin v. Löwis) writes:

> Andrew Koenig <ark at> writes:
> > Now that Tcl/Tk 8.4 is out, can anyone tell me whether Python 2.2.1
> > will work with it?  
> It appears to work fine here, and I can't see a reason why it would be
> incompatible. Notice that the of 2.2.1 is already prepared to
> search for Tcl/Tk 8.4 on its own.

Can ActivePython be persuaded to use TCL 8.4? I notice it has its own
internal TCL 8.3 DLLs etc. If I install TCL 8.4, will Python notice?

Hmm, experimenting, it looks like it doesn't. So I must have to tell
Python to use the installed TCL 8.4. How?


More information about the Python-list mailing list