RedHat 7.3 and Python2.2.1

Kow Kuroda kkuroda at
Mon Sep 2 22:41:00 EDT 2002

On Monday, September 2, 2002, at 06:59 , Peter Hansen wrote:

> Kow Kuroda wrote:
>> On Monday, September 2, 2002, at 11:43 , Peter Hansen wrote:
>>> Doug Farrell wrote:
>>>> I'm trying to install the latest version of Python
>>>> (python2-2.2.1-1.i386.rpm) from the download page, and
>>>> I'm having problems. When I run
>>>> rpm -i python2-2.2.1-1.i386.rpm
>>>> I get all kinds of conflict messages like this:
>>>> file /usr/bin/pydoc2 from install of python2-2.2.1-1 conflicts with
>>>> file from package python2-2.2-16
>>> Sounds like you already have a previous version of Python2.2 installed.
>>> You should probably be using the "-U" option to update instead of
>>> the "-i" option to install... or uninstall the previous one first.
>> I just wanted to make a comment on Peter's post.
>> I think -U or --upgrade option works, but it's dangerious to uninstall 
>> Python 2.1, which is now part of Red Hat Linux 7.3, unlike in prevous 
>> releases where Python 1.5.2 or something is used for installation scripts.
> (Note he had a conflict with Python 2.2, not 2.1.  It should work fine.)

I actuall *did* have a big problem with 2.1 when I tried to install 2.2.1.
  I don't really remember all the error messages I got then.
> Your comments about RH7.3 don't quite fit with my experience.  I just
> installed it (posting from the machine it's on, in fact) and "python"
> executes 1.5.2 still, while "python2" executes 2.2, not 2.1.  What am
> I missing?

Hmmmm, that's odd ... But unfortunatley, I cannot be very precise about 
what I exlained partly because I'm back to RHL 7.2 now. I had some 
embarassing experiences with RHL 7.3 including the problem I described in 
my comments.

All I can say right now is just that I nearly gave up the idea of 
installing 2.2.1 on RHL 7.3 because of the overwhelmingly complicated 
situation with dependencies.

Oh yes, I also tried to update "redhat-config-network" to the most recent 
version, (I needed it to add the wireless interface to "neat"). It requires 
a newer version of Alchemist package, writtin in Python 2.x. And Alchemist 
depends on a newer version of PyGnome, which depends on something, etc, etc.

I admit that it's possible that my situation wasn't typical, but believe me,
  it's true that I got stuck in a very complicated situation caused by 
Python 2.2.1 installation on RHL 7.3.

As a last thought, doesn't Red Hat have different versions of the 7.3 


More information about the Python-list mailing list