linking extension modules w/ "ld" on Solaris - to be expected?

yaipa yaipa at
Fri Sep 20 16:17:34 EDT 2002

Skip Montanaro <skip at> wrote in message news:<mailman.1032463585.12006.python-list at>...
> Alan> I've tried compiling both Python 2.1.1 and 2.2.x on Solaris 8 and
>     Alan> 9 with gcc 2.9x and 3.x in my path. I consistently get the same
>     Alan> build error each time, so it is likely that there is some *switch*
>     Alan> I am not setting somewhere.  
>     ...
>     Alan> gcc -c -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I. -I./Include
>     Alan> -DHAVE_CONFIG_H  -DBUILD=`cat buildno` -o Modules/getbuildinfo.o
>     Alan> ./Modules/getbuildinfo.c
>     Alan> rm -f libpython2.2.a
>     Alan> ar cr libpython2.2.a Modules/getbuildinfo.o
>     Alan> gmake: ar: Command not found
> You need /usr/ccs/bin in your PATH.  That's where ar and several other
> compilation- and link-related commands live, not just compilers proper.

Bing! Da-Bang! Da-Boom!  Worked like a champ.  Thanks Skip.

More information about the Python-list mailing list