PyQT and Eric

Daniele Trovato daniele.trovato at teleport.ch
Wed Apr 16 21:00:55 CEST 2003


@Phil   I hope the answers helpful enough !
> What version of PyQt?
3.5-54

> python -c "from qt import qVersion, PYQT_VERSION"
Traceback (most recent call last)
File "<string>", line 1, in ?
File "/usr/lib/python2.2/site-packages/qt.py", line 39, in ?
import libqtc
ImportError: /usr/lib/python2.2/site-packages/libqtcmodule.so: undefined
symbol: _ZNK16QAssistantClient9classNameEv

> Can you run any of the PyQt examples?
No but I have the same error output
Traceback (most recent call last)
File "<string>", line 1, in ?
File "/usr/lib/python2.2/site-packages/qt.py", line 39, in
.....................................................

@Günter
>Install PyQt sources and recompile. Fixed the problem for me
I will try it, but I'm not an expert in recompile sources an installing it.
_____________________________________________________________________
Thanks
Daniele







More information about the Python-list mailing list