Zope-Dev: Curious Problem += Anxiety

stuffduff stuffduff at cox.net
Fri Apr 25 23:13:47 CEST 2003


I spent the day rebuilding my laptop.

python 2.1.3 from source and then zope 2.51 built & running on the new
python.

I don't think python's the problem, I think zope is.

I even tried moving the class definition inside the function
definition, (how could zope miss it there?); but still no joy.

Something in zope must be intercepting something is my guess,

Curiosity += Anxiety, (or it's going to be a very long weekend)

Sean

home: stuffduff at cox.net
work: swduffy at unmc.edu

On Fri, 25 Apr 2003 14:58:27 GMT, "<stuffduff>"
<just.say.no.to.spam at cox.net> wrote:

>Hi,
>
>I have a python external method which reads from an external database,
>unpickles a class object, and concatenates some of the object's
>properties into a string which is returned by the external method.
>The class definition is included in the module.
>
>When I run it from the linux prompt in the Extensions directory it
>behaves exactly as it should. The class is successfully unpickled, the
>properties are read and the string is returned.
>
>However, when I set it up as an external method and call it I get the
>infamous:
>
>Error Type: SystemError
>Error Value: Failed to import class MyObject from module __main__
>
>From my perspective Zope should be 'blissfully unaware' of the
>existence of the class or the instantiation of the object.  Since the
>object is only accessed in the external method, the module contains
>the class definition, and only a string is returned, why is this
>happening?
>
>What am I missing here?
>
>Platform: Red Hat 7.3, Python 2.1.3, Zope 2.51
>
>Curious,
>
>Sean
>
>P.S. Also posted to zope-dev but I wanted the 'python' perspective as
>well





More information about the Python-list mailing list