compatibility problem

Steven Taschuk staschuk at
Thu Apr 17 04:19:57 CEST 2003

Quoth Chad Scherrer:
> Python 2.1 gives the correct solution, but somehow 2.2.2 is only
> giving me a subset. Not only that, but the order is different! The
> ordering is arbitrary anyway, but I would still expect it to be
> consistent between the two.

This doesn't answer your question, but:  If your code has a decent
suite of unit tests, surely they'll pinpoint the problem for you
in a hurry.  If you have no unit tests, maybe this is an
opportunity to write some.

Steven Taschuk                           staschuk at
"I'm always serious, never more so than when I'm being flippant."
                            -- _Look to Windward_, Iain M. Banks

More information about the Python-list mailing list