Path Problem on W2K?

Bengt Richter bokr at
Sun Aug 17 21:29:26 CEST 2003

On 17 Aug 2003 10:27:17 -0700, hokiegal99 at (hokiegal99) wrote:

>I installed Python-2.3 into c:\Program Files\Python23 on a new W2K SP4
>computer. When I write a Python script and run it from the command
>prompt, I get the following error:
>C:\>python ''
>'python' is not recognized as an internal or external command,
>operable program or batch file.
>Here's what my path contains:
>SystemWorks\Norton Ghost\";C:\Program Files\SSH Communications
>Security\SSH Secu
>re Shell
>Any ideas? I've reinstalled and rebooted several times. Also tried
>adding c:\Program Files\Python23 to my path... still get the error.

I generally avoid installing in c:\Program<abominable_space>Files\anything.
The space just creates a nuisance when you want to use the path simply
in other contexts than they had in mind. Could be that's happening.

If you don't get a simple answer, I would uninstall and then reinstall as
c:\python23\... or c:\myInstalls\python23\ etc. I use a separate partition
and put it at D:\python23\...

Then add ;C:\python23 or whatever you decide (something without embedded spaces ;-)
onto the path.
( probably settings>control panel>system>environment>... or similar on your system).
If you are in a console window, you will have to restart that, at least, for the path
change to show up, if it works like mine.


Bengt Richter

More information about the Python-list mailing list