2.3: test test_normalization failed

Martin v. Löwis martin at v.loewis.de
Sun Aug 31 03:37:24 CEST 2003


Michael Hudson <mwh at python.net> writes:

> > Sounds reasonable. So the 2.3 normalization is just incomplete
> > regarding the newest standard.
> 
> Yep.  I would guess it likely that 2.4 will be up to date again, but
> it's not really my field.

It will be tricky to update. Python now also supports IDNA
(encodings/idna.py), which implements RFC 3490/91/92, which requires
the Unicode 3.2 database; updating to 4.0 would be a violation of that
RFC. So if we want to update the database, we need to find a way still
to keep the old one.

Regards,
Martin




More information about the Python-list mailing list