PyQT installation problems

Greg Fortune lists at gregfortune.com
Wed Aug 20 18:04:05 CEST 2003


First, there's a PyQT (actually called PyKDE) list for discussing these
problems and you might get a more insightful answer there.

Second, I've had problems exactly like that on machines when I tried to use
the version of qt supplied with the distro.  I'm not sure if I didn't get
all the development headers installed, etc, but I've never had a problem
when I compiled a new version of qt on the machine and then compiled/linked
all the PyQt stuff against that new version.  Just make sure you point all
the PyQt related compilations at the new version of qt.

Obviously, there's a lot of time/work involved in the solution above and the
PyQt mailing list might have a better answer, but this should be a pretty
failsafe solution...

Greg Fortune
Fortune Solutions

Stelian Iancu wrote:

> Hello all!
> 
> I am trying to install eric3, the Python IDE. I've downloaded and
> installed successfully sip-3.8, QScintilla-1.2 and PyQT-3.8. However, when
> I try to install eric, I get the following error:
> 
> Sorry, please install PyQt.
> 
> I looked into the install script, then I opened a Python window and there
> I tried import qt and I got the following error:
> 
> Traceback (most recent call last):
>   File "<stdin>", line 1, in ?
>   File "/usr/lib/python2.2/site-packages/qt.py", line 25, in ?
>     import libqtc
> ImportError: /usr/lib/python2.2/site-packages/libqtcmodule.so: undefined
> symbol: _ZNK9QSGIStyle9classNameEv
> 
> I am using Mandrake 9.1 with the default Python (2.2.3) and Qt.
> 





More information about the Python-list mailing list