Carl Banks imbosol at
Fri Aug 8 00:07:07 CEST 2003

Jean-Pierre Andreaux wrote:
> Gmpy module was a wrapper of the GNU MP library. It seems that no
> evolution is done on this module since 2001. Indeed, Gmpy is not
> supported in Python 2.2 nor 2.3.
> My question is the following: what is the better replacement solution
> for manipulating long numbers. I want to do long numbers
> exponentiations. Thanks in advance for your answers.

An alternative is egenix mxNumber package, still in beta stage.

I couldn't use gmpy because I needed floating point, and mxNumber also
wraps the floating point functionality.  It seemed to work ok.

"You don't run Microsoft Windows.  Microsoft Windows runs you."

More information about the Python-list mailing list