Fatal Python error: Interpreter not initialized (version mismatch?) - Solution

Chris Matuszewski ganamide at msn.com
Sun Aug 24 04:59:22 CEST 2003


Potential Solution!

I had this problem when I built an extension module using a debug
version of python.lib.  The problem occured when attempting to import
the extended module with the release version of the python executable.

This solution will probably work vice versa.

So if you link to pythonxx_d.lib, then use python_d.exe (on windows)
If you link using pythonxx.lib, then use python.exe




More information about the Python-list mailing list