a twisted question

Andrew Bennetts andrew-pythonlist at puzzling.org
Tue Aug 19 02:49:53 CEST 2003

On Mon, Aug 18, 2003 at 10:23:38PM +0000, xam wrote:
> Hi All,
> I have got a bit of a complicated situation here:
> I need to get buildBot (and hence twisted) running on RH 7.1, which
> currently has python 1.5 installed. From browsing newsgroups it appears that
> I cannot overwritte 1.5 due to some RH scripts relying on that version. So:
> 1) can twisted run on 1.5? I could not find this info in the docs.

Current Twisted requires Python 2.2 (it also works with 2.3).

> 2) if not, can it run on parallel-installed later version?

Sure, although I don't know the details of doing this under Red Hat 7.1.

> 3) if so, could someone give me a hint on installing a parallel version?

Failing all else, you could download the latest 2.2 (or 2.3) source tarball
from python.org, and compile and install it to /usr/local, but then you
don't get the benefit of RH's package managment...


More information about the Python-list mailing list