Python 2.3 IDLE doesn't show on Win2000

Vin Jovanovic fractal97 at comcast.com
Sat Aug 2 09:37:06 CEST 2003


Trying to start Python IDLE through Start>Programs>Python 2.3> IDLE doesn't
work

>From DOS ... I get this ....

C:\>python C:\Python23\Lib\idlelib\idle.py
Traceback (most recent call last):
  File "C:\Python23\Lib\idlelib\idle.py", line 23, in ?
    idlelib.PyShell.main()
  File "C:\Python23\lib\idlelib\PyShell.py", line 1264, in main
    root = Tk(className="Idle")
  File "C:\Python23\lib\lib-tk\Tkinter.py", line 1564, in __init__
    self.tk = _tkinter.create(screenName, baseName, className)
_tkinter.TclError: Can't find a usable init.tcl in the following directories
    {C:\ptc\dataserver\intralink\tools\lib\tcl} {C:\ptc\dataserver\intralink
ls\lib\tcl} C:/ptc/dataserver/intralink/tools/lib/tcl8.4 c:/python23/lib/tcl
c:/lib/tcl8.4 c:/library

C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac
 "Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
    while executing
"package require -exact Tcl 8.2"
    (file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
    invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"
C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac
 "Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
    while executing
"package require -exact Tcl 8.2"
    (file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
    invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"


This probably means that Tcl wasn't installed properly.






More information about the Python-list mailing list