Installing PyOpenGL - can't find libnumarray module

Mike C. Fletcher mcfletch at rogers.com
Tue Dec 30 07:08:31 CET 2003


Steven Gutstein wrote:

>"Mike C. Fletcher" <mcfletch at rogers.com> wrote in message 
>
>  
>
>>Basically, to fix the problem, uninstall NumArray and install NumPy 23.0.
>>    
>>
>I tried this, without success. 
>I also find I get the same error when I type
>
>from numarray import *
>  
>
You are trying to import a package you just un-installed?  Is this line 
showing up from some other package you're trying to run and you're 
debugging by trying it at the Python prompt?  A Numpy import looks like 
this:

    from Numeric import *

AFAICS, there's nothing named numarray anywhere in a Numpy 23.0 
installation, so if you get that working, then you've not got NumArray 
purged yet.

However, since your original problem was an import error, "the same 
error" probably (posting exception tracebacks is useful) indicates that 
you're getting an ImportError saying that numarray doesn't exist.  
That's what you *want* (since you don't want NumArray hanging around).

>I'm wondering if there's some problem with the fact that libnumarray
>is a .pyd file. I came across a comment that for some reason .pyd
>files don't get found and what I should do is create the following
>setup.cfg file:
>  
>
<lot of py2exe setup stuff snipped>

This is only for creating stand-alone executables, it has nothing to do 
with just running PyOpenGL.  It's also related to NumArray, *not* Numpy, 
so again, not relevant.

>Is there something
>obvious that I'm missing here ?
>  
>
Hopefully not any more.

Good luck,
Mike

_______________________________________
  Mike C. Fletcher
  Designer, VR Plumber, Coder
  http://members.rogers.com/mcfletch/








More information about the Python-list mailing list