New 2 Pythom - Library question !

Laura Creighton lac at strakt.com
Wed Feb 12 17:55:44 CET 2003


> Ian Pellew <ipellew at pipemedia.co.uk> wrote:
> > Hi;
> > 
> > I am new to python so a Question:-
> > 
> > I have just installed python_2_21 into Solaris 8 on a Netra.
> > 
> > Trying to run the cgi.py example program and I get:-
> > python cgi.py                            
> > Traceback (most recent call last):
> >   File "cgi.py", line 39, in ?
> >     import urllib
> >   File "/usr/local/lib/python2.1/urllib.py", line 26, in ?
> >     import socket
> >   File "/usr/local/lib/python2.1/socket.py", line 41, in ?
> >     from _socket import *
> > ImportError: ld.so.1: python: fatal: libssl.so.0.9.6: open failed: No
> > such file or directory
> > "
> > 
> > Suggestions please.
> 
> Have you installed Python from a package? e. g. from sunfreeware.com?
> Anyways, you need OpenSSL installed in order to use sockets under your
> Python.
> 
> At the place you got Python from there will probably also be an OpenSSL
> package available.
> 
> -- Gerhard
> -- 
> http://mail.python.org/mailman/listinfo/python-list

Last time I had that problem I had to build the libraries unshared.
But I didn't investigate it much; I was in a hurry and doing that
worked.

Laura





More information about the Python-list mailing list