Newbie question - Python mode in SciTE ? (NOT solved)

Alan James Salmoni alan_salmoni at yahoo.com
Mon Feb 3 15:03:58 CET 2003


Hi Henri,

I'm not sure if this is what you're after, but I had a similar problem
with SciTE (now my favourite editor!). What I did was to move SciTE to
/usr/share/scite (or is it /usr/share/SciTE ?) as the binary appears
to have that location hard coded. It might be alterable, but I', not
sure how.

Once I moved all the files there, it worked a treat - all the
properties were accessible (remember when you move them to change the
permissions as root will have to create the directory in /usr/share),
and the Go etc stuff works.

Best of luck, and sorry if this doesn't help.

Alan James Salmoni
SalStat Statistics
http://salstat.sunsite.dk

Henri Chorand <henri at nospam.xtradoc.com> wrote in message news:<3E3D3FCA.2020501 at nospam.xtradoc.com>...
> >> My question is, what should I do in order to specify Python as my 
> >> source language, or does SciTE recognize the source language from
>  >> the file extension, or else...
> > 
> > I went back to SciTE documentation, which explicitly says highlighting 
> > is based on source file's extension.
> 
> Well, EXCEPT I can't make it happen and I've got a weird problem.
> I only hope it's the right N.G. for this question.
> 
> 
> So, I strictly followed the instructions provided at:
> http://www.scintilla.org:
> 
>  > A full download (450K) includes the SciTE executable, configuration
>  > files and documentation. After downloading the file, gunzip and
>  > untar it, and run SciTE.
>  > The files required to run SciTE are SciTE which is best located on
>  > the path (I put it in /usr/local/bin) and 27 properties files which
>  > should be located in the /usr/local/share/scite directory.
> 
> I did exactly follow this setup.
> I created a tiny "hello world" script with SciTE and I can now run it in 
> a shell with: python script_name.py
> 
> I'm trying to follow instructions provided at:
> http://www.scintilla.org/SciTEDoc.html
> 
> I run SciTE via a KDE desktop shortcut which runs:
> '/usr/local/bin/SciTE'
> 
> BUT in SciTE, I cannot access any of the following Options menu's items:
> Open Local Options File
> Open User Options File
> Open Global Options File
> Open Abbreviations File
> 
> Instead, when I try selecting the first one, I'm getting the following 
> error message:
> Could not open file '/home/henri/(my folder)/SciTE.properties'.
> 
> After that, SciTE's toolbar indicates SciTE.properties
> (it tries to edit the corresponding setup file, about which I know 
> nothing, and therefore creates it as an empty file)
> 
> Also, the Compile / Build / Go / Stop Executing items in Tools menu are 
> disabled.
> 
> Something very basic must have gone wrong but I can't tell what.
> 
> Any help greatly appreciated!
> 
> Henri




More information about the Python-list mailing list