compiling mysql-python for python 2.3 on windows

Scott David Daniels Scott.Daniels at Acm.Org
Sat Jul 19 20:07:14 CEST 2003


Achim Domma wrote:
> Hello,
> 
> I need mysql-python for python 2.3 on windows. I downloaded the source and
> tried to build it myself, but I get linker errors:
> 
> mysqlclient.lib(password.obj) : error LNK2001: unresolved external symbol
> __ftol2
> 
> The problem seems to be, that the mysql lib is build with VC7, but distutils
> tries to compile with VC6 (which are both on my machine). Can I force
> distutils to use VC7? Or has somebody prebuild binaries for windows? Or has
> somebody another hint on how to get it working on windows? I have also mingw
> 3.2 installed, if it would be helpfull!?
> 
> regards,
> Achim

At least by rc1, 2.3 distutils supports VC 7.1.  Perhaps that fix
will allow VC7, and perhaps not.  Check the newest distutils docs
anway.

-Scott David Daniels
Scott.Daniels at Acm.Org






More information about the Python-list mailing list