Fw: Python-2.3c2.tgz installation

Dave Reed drlinux at columbus.rr.com
Wed Jul 30 00:09:10 CEST 2003


On Tuesday 29 July 2003 16:59, Sanjiv Kumar wrote:
> 
> Hi,
> 
> I am trying to build and install python-2.3 on a Solaris machine. It 
give segmentation fault during build process ( I guess during build of 
extensions to python i.e. running "build_ext").  I am using gcc 
--version 2.95.2 on SunOS xyz 5.8 Generic_108528-15 sun4u sparc 
SUNW,Ultra-60 machine. So any hint to get rid of this problem.
>  
> Best Regards,
> =Sanjiv=

If the compiler gives a segmentation fault, I would think it's a bug
in the compiler or it wasn't installed correctly. gcc 2.95.2 is pretty
hold and I suspect (well, all code that large has bugs) it had bugs -
there is a 2.95.3.

I can report successful compilation of Python 2.3c2 on Solaris 9 using
gcc 3.2.3.

I would first try upgrading your compiler to 2.95.3 or gcc 3.2.3 or
maybe even gcc 3.3 (I haven't looked to see how bug-free it is
supposed to be). The latest Red Hat beta does include it so they must
have got it to compile all their packages.

Dave (who is patiently waiting for the final 2.3 so he can finish
updating software on Solaris 9 machines)







More information about the Python-list mailing list