Good code patterns in Python

Lulu of the Lotus-Eaters mertz at
Tue Jul 1 20:26:51 CEST 2003

|hwlgw at (Will Stuyvesant) wrote:
|>     if some_condition:
|>         some_name = some_value
|>     else:
|>         some_name = other_value
|> is often a mistake.  Much better, safer, would be:
|>     some_name = some_value
|>     if not some_condition:
|>         some_name = other_value

mis6 at (Michele Simionato) wrote previously:
|I am sorry, but I feel that the first form is MUCH more readable than the
|second one; the first form is crystal clear to me, whereas I must read
|the second form two or three times to understand what it is going on.

Moreover, actual code often assigns from computations, not simply one
name to another.  The harder-to-read form risks bad side effects (or
simply a performance hit):

    some_name = some_computation()
    if not some_condition:
        some_name = other_computation()

The straightforward if/else form avoids superfluous computations.

Yours, Lulu...

 mertz@   _/_/_/_/_/_/_/ THIS MESSAGE WAS BROUGHT TO YOU BY:_/_/_/_/ v i
gnosis  _/_/                    Postmodern Enterprises         _/_/  s r
.cx    _/_/  MAKERS OF CHAOS....                              _/_/   i u
      _/_/_/_/_/ LOOK FOR IT IN A NEIGHBORHOOD NEAR YOU_/_/_/_/_/    g s

More information about the Python-list mailing list