Any pure-python relational databases?

Terry Reedy tjreedy at
Sat Jul 12 21:27:20 CEST 2003

"David McNab" <postmaster at> wrote in message
news:pan.2003. at
> The server runs Python 1.5.2,

> The web host is my client's choice, not mine, and there's very
> prospect of getting them to upgrade their python or install

In 1999, Guido posted to "On April 13, the *final* version of
Python 1.5.2 was released." [*emphasis* added]

How much untouched-in-four-years software does your client depend on
for critical business processes, one might wonder ;-)

IE4?  Win98SE without Y2K + security upgrades?  Win95 last updated
four years ago?

If you want to discuss this with your clients, you can point out that
just as IE6 does not run (or even install) on Win95, there are many
Python modules that do not run on Python 1.X, and for much the same

Good luck.

Terry J. Reedy

More information about the Python-list mailing list