python2.0, _socket module, builtin, compile

wavegroom wavegroom at gmx.net
Mon Jun 2 18:24:06 CEST 2003


hi 

First my config:
Athlon 1.8 GHZ
latest gentoo-linux and w2k
python2.2 and python 2.0.1

I have a problem with python 2.0. I use Blender (2.25) wich has a built 
in python engine (python2.0).
I tried to import the socket module, but I get the error message module 
_socket not found. I added a python 2.0.1 installation for blender, so 
that I have all modules.

Its so that blender python doesn't have all builtin modules. On windows 
it works because the built in modules are not static linked to 
python.exe. On linux the _socket module ins integrated in the python-bin.

How can I compile python 2.0.1 under linux, so that i get the built in 
functions as non static modules, so that i can load _socket.so at 
runtime. (like in python2.2)

I tried a bit to modify some config files from the source, but nothing 
worked :-(

any help would be very welcome :-)))




More information about the Python-list mailing list